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1. Z kurzu pfedmétu na elearning.tul.cz stdhnéte a rozbalte projekt LABO3.zip.
Cesta k projektu nesmi obsahovat diakritiku, mezery nebo specialni znaky. Vhodné umisténi
je v laboratori A107 vase domovska sloZka, ve kterém si mizZete vytvorit podadresar s vasim
Jjménem bez diakritiky.
2. Otevrete Vivado — dvakrat kliknéte na spoustéc¢ na plose:
3. V uvodnim okné aplikace kliknéte na Quick Start — Open Project:
Eile Flow Tools Window  Help
Vivado
ML Edition
Create Project >
Open Project »
Open Example Project >
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a. PFipadné upozornéni o novéjsi verzi prostredi, nez je projekt vyfeste automatickym
upgrade projektu:

Older Project Version VoA X

This project was created using an older version of Vivade. It is strongly recommended that you backup
the project prior to migration by opening the project in the older version of Vivado (v2023.1) and LA
running "File-=Archive Project”. This will ensure all sources, including any IPs used by the design, are
preserved properly. Choose to either automatically upgrade to the current version or open the project
in read-only mode.

What do you want to do?
(®) automatically upgrade to the current version

() Open project in read-only mode

b. Otevie se okno s otevienym projektem:

# LABO3 - [C/work/2023/CITE/LABO3/LABO3/LABD3.xpr] - Vivado 20201 - o X
Hle Edit Flow Tools Repons MWindow Layour \View Help O QuickAccess Ready
= =] X b B o T b = Default Layout v

Flow Navigatr ERN AN PROJECT MANAGER - LABD ? X

~ PROJECT MANAGER B

Sources. 2 -0 G x| |Projectsummary x| lab03vhd 200
& Settings
Q E|& + 0 @0 o« c ITE/LABO3/L 1/new/lab03vhd
Ada Sources
[ ~ &= Design Sources (1) Q | - X B B X / = 9 o
P 1P Catal s C:m“ ines (i library IEEE: N
analeg - gt use IEEE.STD_LOGIC_1164.ALL;
~ % constrs 1 (1)
¥ IPINTEGRATOR I nexysdddrxdc entity lab03 is
Create Block Design Simulation Sources (1 port (
sm 1 a : in std_logke:
Utility Sources , 9 : out atd logle
. 7
10 end 1ab03;
¥ SIMULATION architecture Behavioral of lab03 is
Run Simulation i il o i
Hierarchy  Libraries  Compile Order cignal invertor : std_logle:
~ RTLANALYSIS Source File Properties ?.D0GX begin
~ Open Elaborated Design L] -
ab03ehd h invertor <= not a;
Report Methodology . A q <= invertor;
) Enabled
Rey DRC
ot JRpsseas it ann sonar nam et ¥ end Behaviorals
H Schematic v
General  Properties < >
v SYNTHESIS
TclConsole x Messages |Log Reports  DesignRuns 2 _00
P Run Synthesis o
Q = &£ Il B ®E @
# Open Synthesized Design
Parsing XDC File [C:/work/2023/CITE/LABOI/LABO3/LABOI. sxes/constrs_l/imports/PO/nexysdddr. xde] N
Finished Parsing XDC File [C:/werk/2023/CITE/LABO3/ constrs_L/imp " xde]
~  IMPLEMENTATION i =
» Run Implementation
> Open Implemented Design
¥ PROGRAM AND DEBUG < b
¥ Generate Bitstream ol [t
623 Insert_ VHDL

4. V okné Sources rozbalte slozku Design Sources a dvakrat kliknéte na soubor

lab03 (lab03.vhd). Otevie se okno editoru s pfedpfipravenym kédem v jazyce VHDL.
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5. PovSimnéte si:

a. Kazdy VHDL soubor obsahuje deklarace pouzitych knihoven:

library IEEE;
use IEEE.STD_LOGIC_1164.ALL;

b. Vnéjsi popis obvodu ve formé entity. Nas obvod se jmenuje 1ab03 a obsahuje

deklaraci portt — vystupniho portu q_inv a vstupniho portu a:

entity 1labe3 is

port(
a : in std_logic;
g_inv : out std _logic
)
end 1abo3;

c. Popis chovani nebo struktury vnitfku obvodu, ktery se nazyva architektura a je
pfifazen k nasi entité. V naSem pfipadé je architektura structural pfifazena k entité
lab03:

architecture structural of 1abe3 is
signal invertor : std_logic;
begin

invertor <= not 3a;
g_inv <= invertor;

end structural;

d. Architektura se sklada z deklaraéni Casti a z téla. V deklaracni Casti je deklarovan
signal invertor. V téle architektury se nachazi paraleini pfikazy. V nasem pfipadé

dva pfikazy nepodminéného pfifazeni.
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Upravte kod:
a. Do deklarace portl pfidejte vstupy b, ¢ typu std_logic.
b. Do deklarace portl pfidejte vystupy q_log0, q_log1, q_and, q_or, q_xor, q_xnor,
q_nand, g_nor typu std_logic.

Zaznamy v sekci port jsou oddélovany stfednikem

Za posledni zaznam stfednik nepiSeme (dalSi zaznam nenasleduje)

V pripadé stejnych datovych typt a moédu (in, out...) Ize na levé strané zaznamu oddélovat
jednotlivé porty ¢arkou

Nazvy portu jsou v rdmci Vivado case-sensitive

V téle architektury vytvorte tfivstupa hradla AND, OR, XOR, XNOR, NAND, NOR se vstupy a,
b, c. Napf. pro hradlo XOR.

nebo

g_xor <= a xor b xor c;

g _xor <= xor(a, b, c);

a. Hradla AND, OR, XOR a XNOR vytvofte pomoci pfikazll operatord and, or, xor,
xnor.

b. Hradla AND a OR vyuzijte pro vytvofeni hradel NAND a NOR (s pomoci operatoru
logické negace not)

c. Na vystupy q_log0, a q_log1 pfifadte odpovidajici konstanty. Konstanta datového

typu std_logic je typu znak a piSeme ji do jednoduchych uvozovek, napf. log O je '0".
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8. Kliknéte tlacitko Schematic v oddilu Flow Navigator (vlevo) v podskupiné RTL analysis. Na

obrazku zvyraznéno oranzove:

#% LABO3 - [C:/work/2023/CITE/LABO3/L.

File
) B

Edit  Flow Tools
Flow Navigator =
~ PROJECT MANAGER

£ Settings
Add Sources

Language Templates

% IP Catalog

~ IPINTEGRATOR
Create Block Design
Open Block Design

Generate Block Design

¥ SIMULATION

Run Simulation

~ RTL ANALYSIS

 Open Elaborated Design

Report Methodology
Report DRC

Report Noise

v SYNTHESIS

P Run Synthesis

- [m] be

ABO3/LABO3xpr] - Vivado 2020.1
Reports  Window  Llayout  View  Help Q- Quick Access Synthesis Out-of-date details <&

X o p B X & z x = 1/O Planning v
= ELABORATED DESIGN - xc7a100tcsg324-1 ? X
“| @ Elaborated Design is out-of-date. Design sources were modified. details -

Source Net x Devic, 2 _ O X Package x| Device x- * Schematic 200

P | & Q @ M N 9 C  1Cell 21/OPorts 2 Nets -3

lab03
> = Nets (2)
> Leaf Cells (1)
invertor_i
10 0] .
a q_inv

Source x ClockReg 2 _ O [X

I nexys4ddrxde RTL_INV

General Properties

TclConsole | Messages | Log |Reports |DesignRuns |PackagePins |1/0Ports x 2 _D0K

Q T & =0 + H o

Name Direction Neg Diff Pair Package Pin Fixed Bank 1/OStd Vcco Vref Drive Strength Slew Type Pull Type  Off-Chip Termination IN_TERM

~ 5 All ports (2)

» v Scalar ports (2)

v

9. Ze schématu ovéfte, ze vas popis vytvofil pfislusna hradla (bude jich vic, nez invertor

z obrazku vyse).

10. Prepnéte na zalozku VHDL kodu (zelené) a zmérite poradi pfikazl. Znovu prozkoumejte

schéma.

a.

Po zméné VDHL kédu a jeho ulozeni (ctrl + s, nebo ikona diskety vlevo nahore
v oknu editoru) se objevi Zluta lista s tlacitkem Reload (na obrazku fuchsiové). Po
kazdé zméné kddu je nutné znovu provést syntézu obvodu.

VsSimnéte si, Ze se vytvofila stejna hradla. ,Ovéfili“ jsme, ze jsou prikazy v téle
architektury paralelni, nezéleZi na jejich poradi.
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11. Nahrajte vas navrh do vyvojové desky:

a. Kliknéte na polozku Generate bitstream v podokné Flow nebo z podmenu Flow:

#  LABO3 - [C/work/2023/CITE/LAB03/LABO3/LABO3.xpr] - Vivado 2020.1 - [m] X
File Edit Flow Tools Reports Window Layout View  Help Q- Quick Access write_bitstream Complete  +/
= Project Manager * == Default Layout v

Flow Navigator, Settings , 3ER - LABO3 ? X

Open Sy
Create Block Design 2 _ 0O X Project Summary % lab03.wvhd 200
~ IMPLEMENT,
+ 0 o Ci/work/2023/CITE/LABO3/LABO3/LABO3 srcs/sources_1/new/lab03vhd  *
» RunImpl Run Simulation > N
rces (1) v
© Openim Open Static Simulation..  F-o-ooooooooo oo Q - % BB X 4/ ® 0 *
raries  Compile Order 1 library IEEE; ~l
Open Elaborated Design |
Cons| 2 | use IEEE.STD_LOGIC_1164.ALL;
New Elaborated Design... L 5
Edit ? 00X 2 ) )
P Run Synthesis 2 - 5 4 ? entity lab03 is
© Repo . . 5 port (
Open Synthesized Design £ o . . ™
R Iy 6 . a : in std_logic;
erd New Synthesized Design... . 7 g Ve =y v
erties < >
Repg ), Run Implementation
Repg Open Implemented Design » Wessages x Log |Reports | Design Runs ?2_00O
Repd Open Hardware Manager T, B @ © Critical warning (20) () @ Warning (24) () @ Info (109) () @ Status (234)| Show All &
Repo M Generate Bitstream 10 critical warnings)
% Rep Create Rups... }mn 17-55] 'set_property’ expects at least one object. [nexys4ddrxdc:14] (9 more like this)
~ I.s Implementation (10 critical warnings)
5 schematic I Design Initialization (10 critical warnings)
> © [Common 17-55] 'set_property’ expects at |least one object. [nexys4ddrxde:14] (9 more like this)
v PROGRAM AND DEBUG
¥ Generate Bitstream
> Open Hardware Manager
|
Generate a programming file after implementation
b. Vyckejte na pop-up okno a zvolte Open Hardware Manager:
Bitstream Generation Completed X
0 Bitstream Generation successfully completed
Next
Open Implemented Design
View Reports
@ Open Hardware Manager
‘::) Generate Memory Configuration File Open the
D Don’t show this dialog again
OK
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c. Pripojte vyvojovou desku k USB portu PC. Pfepnéte prepina¢ POWER do polohy
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d. Na zelené listé ve Vivado kliknéte na Open target. Vyberte polozku Auto Connect

¢ LABOS - [C/work/2023/CITE/LABO3/LABO3/LABO3.xpr] - Vivado 2020.1

] X

File Edit Flow Tools Reports Window Layout View He & write_bitstream Complete

= B X r B @ Z ¥ Dashboard &= Default Layout v
Flow Navigator E HARDWARE MANAGER - unconnected ? X
B Report Methodology i @ No hardware target is open. Open target
Report DRC 1
epo e & Auto Connect
lardware 5
"1 Schematic pox
& 1 W X
¥ SYNTHESIS Nol Open New Target... a7
P Run Synthesis S |
Source File Properties ? 00X
> Open Synthesized Design 2 !
I nexys4ddr.xdc & 3
= 40 -
~  IMPLEMENTATION (G bl -
P Run Implementation General [RBropelis
~  Open Implemented Design
Tcl Console < Messages Serial 1/0 Link¢ Serial I/OSca| 2 _ O 3
Constraints Wizard .
Q = 2 Il B WM @
Edit Timing Constraints Type a Tcl command here
v

Martin Rozkovec, martin.rozkovec@tul.cz

Technicka univerzita v Liberci | Fakulta mechatroniky, informatiky a mezioborovych studii | ITE
Studentska 1402/2, 461 17 Liberec 1 | www.fm.tul.cz

8/9



FAKULTA MECHATRONIKY, ) \Q\ué/
INFORMATIKY A MEZIOBOROVYCH AN/

. e
STUDIT TUL o n—

e. Pravym tlagitkem kliknéte na polozku xc7a100t_0 a zvolte Program Device (viz

obrazek dole). V dal$im dialogu kliknéte na tlac¢itko Program.

¢ LABO3 - [C:/work/2023/CITE/LABO3/LABO3/LABO3.xpr] - Vivado 2020.1

File Edit Flow Tools Reparts Window Layout View Help

= - 0] | R I - S x Dashboard ~

HARDWARE MANAGER - localhost/xilinx_tcf/Digilent/210292645777A
Jpe Y - A

© There are no debug cores. Program device Refresh device

v IMPLEMENTATIOI

Hardware 2 _ OO X | lab03vhd x nexysdd
P Run Implemer > &
Q %|6 o C:/work/2023/CITE/LABO3
v Open Implem
Name Status Q -
Constraint 1 localhost ot
|
Edit Timir B+ xilinx_tcf/Digilent/ Hardware Device Properties...
® Report Tir ® xc72100t 0 (1) Program Device...
XADC e Verify Device...
Report Cl¢
C  Refresh Device
Report Cl

Hardware Device Properties Show Bus Plot...

21 Rannrt M.

12. Ovéfte funkci hradel dle pravdivostnich tabulek. Vstupy c, b, a jsou namapovany na

pfepinace, vystupy hradel na LED diody nad pfepinadi, viz obrazek vy3e.

13. Otevrete okno s editorem kédu a upravte VHDL soubor:

a. Doplrite vystupni port q_vote typu std_logic.
b. Doplnte vstupni port d typu std_logic

14. Do téla architektury pfidejte obvod, ktery realizuje funkci tajného hlasovani spravni rady.
a. Vstupy: a=pfedseda, vstupy b, ¢, d = &lenové. Log. 1=Pro, 0=Proti. VSichni &lenové
jsou si rovni, ale v pfipadé shody poctu hlast ma hlas pfedsedy vahu dvou hlasu.
Vystup funkce, ktery indikuje vysledek hlasovani zapojte na vystup q_vote.
b. Pro dil¢i p-termy minimalizované funkce vytvorte v deklaracni ¢asti architektury

signaly (napf. ptermO, pterm1, atp.). Pfiklad deklarace signalu jsou jiz v souboru.

15. Prohlédnéte si navrzeny obvod schéma navrZzeného obvodu v RTL-Analysis\Schematic
16. Nahrajte obvod do hradlového pole a ovéfte jeho funkci.
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